diff src/lib-dict/Makefile.am @ 5197:e77e4457d95c HEAD

Added --with-headers configure option to install .h files.
author Timo Sirainen <tss@iki.fi>
date Thu, 22 Feb 2007 23:50:46 +0200
parents ee745eee4d9c
children 63dd68ae343f
line wrap: on
line diff
--- a/src/lib-dict/Makefile.am	Thu Feb 22 23:49:34 2007 +0200
+++ b/src/lib-dict/Makefile.am	Thu Feb 22 23:50:46 2007 +0200
@@ -18,12 +18,19 @@
 	$(dist_sources) \
 	dict-drivers-register.c
 
-noinst_HEADERS = \
+headers = \
 	dict.h \
 	dict-client.h \
 	dict-private.h \
 	dict-sql.h
 
+if INSTALL_HEADERS
+  pkginc_libdir=$(pkgincludedir)/src/lib-dict
+  pkginc_lib_HEADERS = $(headers)
+else
+  noinst_HEADERS = $(headers)
+endif
+
 dict-drivers-register.c: Makefile
 	rm -f $@
 	echo '/* this file automatically generated by Makefile */' >$@