diff src/lib-imap/Makefile.am @ 5197:e77e4457d95c HEAD

Added --with-headers configure option to install .h files.
author Timo Sirainen <tss@iki.fi>
date Thu, 22 Feb 2007 23:50:46 +0200
parents fb7f862194b5
children 56f55bd35aa5
line wrap: on
line diff
--- a/src/lib-imap/Makefile.am	Thu Feb 22 23:49:34 2007 +0200
+++ b/src/lib-imap/Makefile.am	Thu Feb 22 23:50:46 2007 +0200
@@ -15,7 +15,7 @@
 	imap-parser.c \
 	imap-util.c
 
-noinst_HEADERS = \
+headers = \
 	imap-base-subject.h \
 	imap-bodystructure.h \
 	imap-date.h \
@@ -24,3 +24,10 @@
 	imap-quote.h \
 	imap-parser.h \
 	imap-util.h
+
+if INSTALL_HEADERS
+  pkginc_libdir=$(pkgincludedir)/src/lib-imap
+  pkginc_lib_HEADERS = $(headers)
+else
+  noinst_HEADERS = $(headers)
+endif