diff src/lib-index/Makefile.am @ 5197:e77e4457d95c HEAD

Added --with-headers configure option to install .h files.
author Timo Sirainen <tss@iki.fi>
date Thu, 22 Feb 2007 23:50:46 +0200
parents 967de900c73a
children 0d2a6a7f2a1b
line wrap: on
line diff
--- a/src/lib-index/Makefile.am	Thu Feb 22 23:49:34 2007 +0200
+++ b/src/lib-index/Makefile.am	Thu Feb 22 23:50:46 2007 +0200
@@ -32,7 +32,7 @@
         mailbox-list-index.c \
         mailbox-list-index-sync.c
 
-noinst_HEADERS = \
+headers = \
 	mail-cache.h \
 	mail-cache-private.h \
         mail-hash.h \
@@ -46,3 +46,10 @@
         mail-transaction-util.h \
         mailbox-list-index.h \
         mailbox-list-index-private.h
+
+if INSTALL_HEADERS
+  pkginc_libdir=$(pkgincludedir)/src/lib-index
+  pkginc_lib_HEADERS = $(headers)
+else
+  noinst_HEADERS = $(headers)
+endif