diff configure.in @ 3594:f1b407e8debb HEAD

And more changes to get _XPG6 stuff working right
author Timo Sirainen <tss@iki.fi>
date Sun, 18 Sep 2005 20:50:09 +0300
parents 340e1b87c27b
children 33e3b0899b47
line wrap: on
line diff
--- a/configure.in	Sun Sep 18 20:37:17 2005 +0300
+++ b/configure.in	Sun Sep 18 20:50:09 2005 +0300
@@ -957,6 +957,7 @@
 
 dnl * Check for crypt() if unistd.h compiles with _XOPEN_SOURCE + _XPG6
 dnl * Add other macros there too "just in case".
+AC_MSG_CHECKING([if we should use _XPG6 macro for crypt()])
 AC_TRY_COMPILE([
   #define _XOPEN_SOURCE 4
   #define _XOPEN_SOURCE_EXTENDED 1
@@ -968,6 +969,9 @@
   crypt("a", "b");
 ], [
   AC_DEFINE(CRYPT_USE_XPG6,, Define if _XPG6 macro is needed for crypt())
+  AC_MSG_RESULT(yes)
+], [
+  AC_MSG_RESULT(no)
 ])
 
 dnl ***