diff configure.in @ 739:f50714973d0b HEAD

RLIMIT_AS isn't supported everywhere - use it if it exists, but also use RLIMIT_DATA.
author Timo Sirainen <tss@iki.fi>
date Sun, 01 Dec 2002 23:17:59 +0200
parents 280c0952fa90
children b3dd87844fff
line wrap: on
line diff
--- a/configure.in	Sun Dec 01 20:18:49 2002 +0200
+++ b/configure.in	Sun Dec 01 23:17:59 2002 +0200
@@ -408,6 +408,18 @@
   fi
 ])
 
+dnl * Do we have RLIMIT_AS?
+AC_TRY_COMPILE([
+  #include <sys/types.h>
+  #include <sys/time.h>
+  #include <sys/resource.h>
+], [
+  struct rlimit r;
+  getrlimit(RLIMIT_AS, &r);
+], [
+  AC_DEFINE(HAVE_RLIMIT_AS)
+])
+
 dnl * Linux compatible mremap()
 AC_MSG_CHECKING([Linux compatible mremap()])
 AC_TRY_COMPILE([