diff configure.in @ 4063:f60237ad2edd HEAD

Support Solaris's ioctl(Q_QUOTACTL).
author Timo Sirainen <tss@iki.fi>
date Sat, 25 Feb 2006 11:10:04 +0200
parents f4807accc1d5
children f3e7ee9630d0
line wrap: on
line diff
--- a/configure.in	Sat Feb 25 10:24:18 2006 +0200
+++ b/configure.in	Sat Feb 25 11:10:04 2006 +0200
@@ -1117,6 +1117,20 @@
   AC_MSG_RESULT(no)
 ])
 
+dnl * Check if we have Q_QUOTACTL ioctl (Solaris)
+AC_MSG_CHECKING([if struct Q_QUOTACTL ioctl exists])
+AC_TRY_COMPILE([
+  #include <sys/fs/ufs_quota.h>
+], [
+  struct quotactl ctl;
+  ioctl(0, Q_QUOTACTL, &ctl);
+], [
+  AC_DEFINE(HAVE_Q_QUOTACTL,, Define if Q_QUOTACTL exists)
+  AC_MSG_RESULT(yes)
+], [
+  AC_MSG_RESULT(no)
+])
+
 dnl ***
 dnl *** va_copy checks (from GLIB)
 dnl ***