diff configure.in @ 3720:fd0986477809 HEAD

Initial implementation of Dovecot's own high performance file format, named dbox. Currently relies heavily on index files to work, and isn't able to rebuild them if they're lost. This will be fixed soon. Not tested much yet in general.
author Timo Sirainen <tss@iki.fi>
date Mon, 28 Nov 2005 01:05:28 +0200
parents 561e81dfa20b
children d67092398377
line wrap: on
line diff
--- a/configure.in	Mon Nov 28 01:03:06 2005 +0200
+++ b/configure.in	Mon Nov 28 01:05:28 2005 +0200
@@ -14,7 +14,7 @@
 AM_PROG_LIBTOOL
 AM_ICONV
 
-AC_CHECK_HEADERS(strings.h stdint.h unistd.h dirent.h inttypes.h \
+AC_CHECK_HEADERS(strings.h stdint.h unistd.h dirent.h \
   sys/uio.h sys/sysmacros.h sys/resource.h sys/select.h libgen.h)
 
 # check posix headers
@@ -250,7 +250,7 @@
 AC_ARG_WITH(storages,
 [  --with-storages         Build specified mail storage formats (maildir,mbox)], [
 	mail_storages=`echo "$withval"|sed 's/,/ /g'` ],
-	mail_storages="maildir mbox")
+	mail_storages="maildir mbox dbox")
 AC_SUBST(mail_storages)
 
 AC_ARG_WITH(moduledir,
@@ -1449,6 +1449,7 @@
 
 maildir_libs="../lib-storage/index/maildir/libstorage_maildir.a"
 mbox_libs="../lib-storage/index/mbox/libstorage_mbox.a"
+dbox_libs="../lib-storage/index/dbox/libstorage_dbox.a"
 index_libs="../lib-storage/index/libstorage_index.a ../lib-index/libindex.a"
 
 STORAGE_LIBS=
@@ -1485,6 +1486,7 @@
 src/lib-storage/index/Makefile
 src/lib-storage/index/maildir/Makefile
 src/lib-storage/index/mbox/Makefile
+src/lib-storage/index/dbox/Makefile
 src/lib-storage/subscription-file/Makefile
 src/lib-storage/register/Makefile
 src/auth/Makefile