diff setup.py @ 427:36e644d28edf

Make it possible to specify a version number in setup.py. -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Make it possible to specify a version number in setup.py. manifest hash: 905feb305205801eb3833e5a84161fb57b83c86e -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.1 (GNU/Linux) iD8DBQFCtc/QW7P1GVgWeRoRAlCaAJ9G2GRf0wIEVEbYNoV4PjV4b024bQCfcUFf WVYQlTXqninDXyKas2yQYdo= =ofg/ -----END PGP SIGNATURE-----
author Thomas Arendsen Hein <thomas@intevation.de>
date Sun, 19 Jun 2005 21:04:32 +0100
parents 25afb21d97ba
children 688d03d6997a
line wrap: on
line diff
--- a/setup.py	Sun Jun 19 20:16:10 2005 +0100
+++ b/setup.py	Sun Jun 19 21:04:32 2005 +0100
@@ -11,6 +11,9 @@
 
 import mercurial.version
 
+# specify version string, otherwise 'hg identify' will be used:
+version = ''
+
 class install_package_data(install_data):
     def finalize_options(self):
         self.set_undefined_options('install',
@@ -18,7 +21,7 @@
         install_data.finalize_options(self)
 
 try:
-    mercurial.version.remember_version()
+    mercurial.version.remember_version(version)
     setup(name='mercurial',
         version=mercurial.version.get_version(),
         author='Matt Mackall',