diff setup.py @ 72:4a6ab4d80dc4

Add an O(m + nlog n) patching extension
author mpm@selenic.com
date Mon, 16 May 2005 22:08:33 -0800
parents a182f2561c8e
children 67b8d24d2dbe 083c38bdfa64
line wrap: on
line diff
--- a/setup.py	Sat May 14 10:27:14 2005 -0800
+++ b/setup.py	Mon May 16 22:08:33 2005 -0800
@@ -5,14 +5,15 @@
 # './setup.py install', or
 # './setup.py --help' for more options
 
-from distutils.core import setup
+from distutils.core import setup, Extension
 
 setup(name='mercurial',
-            version='0.4f',
-            author='Matt Mackall',
-            author_email='mpm@selenic.com',
-            url='http://selenic.com/mercurial',
-            description='scalable distributed SCM',
-            license='GNU GPL',
-            packages=['mercurial'],
-            scripts=['hg', 'hgweb.py'])
+      version='0.4f',
+      author='Matt Mackall',
+      author_email='mpm@selenic.com',
+      url='http://selenic.com/mercurial',
+      description='scalable distributed SCM',
+      license='GNU GPL',
+      packages=['mercurial'],
+      ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c'])],
+      scripts=['hg', 'hgweb.py'])