diff setup.py @ 429:688d03d6997a

Pull from TAH -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Pull from TAH manifest hash: 600d04efbd836d555d11a3bd9d821d1d8c0a9790 -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.0 (GNU/Linux) iD8DBQFCuPFxywK+sNU5EO8RAjfzAKC18Zc2EOkXhy1zcpgGnyPHnFMdmgCfW5Ut I5HSWqZMt8H0WJx1Or7ajNc= =27D5 -----END PGP SIGNATURE-----
author mpm@selenic.com
date Tue, 21 Jun 2005 21:04:49 -0800
parents 8b067bde6679 36e644d28edf
children 7f5ce4bbdd7b
line wrap: on
line diff
--- a/setup.py	Tue Jun 21 20:40:53 2005 -0800
+++ b/setup.py	Tue Jun 21 21:04:49 2005 -0800
@@ -9,25 +9,34 @@
 from distutils.core import setup, Extension
 from distutils.command.install_data import install_data
 
+import mercurial.version
+
+# specify version string, otherwise 'hg identify' will be used:
+version = ''
+
 class install_package_data(install_data):
     def finalize_options(self):
         self.set_undefined_options('install',
                                    ('install_lib', 'install_dir'))
         install_data.finalize_options(self)
 
-setup(name='mercurial',
-      version='0.5b',
-      author='Matt Mackall',
-      author_email='mpm@selenic.com',
-      url='http://selenic.com/mercurial',
-      description='scalable distributed SCM',
-      license='GNU GPL',
-      packages=['mercurial'],
-      ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
-                   Extension('mercurial.bdiff', ['mercurial/bdiff.c'])],
-      data_files=[('mercurial/templates',
-                   ['templates/map'] +
-                   glob.glob('templates/map-*') +
-                   glob.glob('templates/*.tmpl'))], 
-      cmdclass = { 'install_data' : install_package_data },
-      scripts=['hg', 'hgmerge'])
+try:
+    mercurial.version.remember_version(version)
+    setup(name='mercurial',
+          version=mercurial.version.get_version(),
+          author='Matt Mackall',
+          author_email='mpm@selenic.com',
+          url='http://selenic.com/mercurial',
+          description='scalable distributed SCM',
+          license='GNU GPL',
+          packages=['mercurial'],
+          ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
+                       Extension('mercurial.bdiff', ['mercurial/bdiff.c'])],
+          data_files=[('mercurial/templates',
+                       ['templates/map'] +
+                       glob.glob('templates/map-*') +
+                       glob.glob('templates/*.tmpl'))], 
+          cmdclass = { 'install_data' : install_package_data },
+          scripts=['hg', 'hgmerge'])
+finally:
+    mercurial.version.forget_version()