diff setup.py @ 3877:abaee83ce0a6

Replace demandload with new demandimport
author Matt Mackall <mpm@selenic.com>
date Wed, 13 Dec 2006 13:27:09 -0600
parents 231e61de692c
children 57b797601b61
line wrap: on
line diff
--- a/setup.py	Tue Dec 12 18:16:23 2006 -0600
+++ b/setup.py	Wed Dec 13 13:27:09 2006 -0600
@@ -13,8 +13,6 @@
 from distutils.core import setup, Extension
 from distutils.command.install_data import install_data
 
-# mercurial.packagescan must be the first mercurial module imported
-import mercurial.packagescan
 import mercurial.version
 
 # py2exe needs to be installed to work
@@ -35,31 +33,6 @@
     except ImportError:
         pass
 
-    # Due to the use of demandload py2exe is not finding the modules.
-    # packagescan.getmodules creates a list of modules included in
-    # the mercurial package plus depdent modules.
-    from py2exe.build_exe import py2exe as build_exe
-
-    class py2exe_for_demandload(build_exe):
-        """ overwrites the py2exe command class for getting the build
-        directory and for setting the 'includes' option."""
-        def initialize_options(self):
-            self.build_lib = None
-            build_exe.initialize_options(self)
-        def finalize_options(self):
-            # Get the build directory, ie. where to search for modules.
-            self.set_undefined_options('build',
-                                       ('build_lib', 'build_lib'))
-            # Sets the 'includes' option with the list of needed modules
-            if not self.includes:
-                self.includes = []
-            else:
-                self.includes = self.includes.split(',')
-            mercurial.packagescan.scan(self.build_lib, 'mercurial')
-            mercurial.packagescan.scan(self.build_lib, 'mercurial.hgweb')
-            mercurial.packagescan.scan(self.build_lib, 'hgext')
-            self.includes += mercurial.packagescan.getmodules()
-            build_exe.finalize_options(self)
 except ImportError:
     py2exe_for_demandload = None