diff setup.py @ 1686:dd5085897010

make stuff for macos x binary package. it is now easy to make prebuilt binary for macos x. i have no hosting space. i hope someone else can make binaries.
author Vadim Gelfer <vadim.gelfer@gmail.com>
date Fri, 03 Feb 2006 00:50:28 -0800
parents 18f3224da392
children 43d3db1b8296
line wrap: on
line diff
--- a/setup.py	Mon Jan 30 19:34:35 2006 +1300
+++ b/setup.py	Fri Feb 03 00:50:28 2006 -0800
@@ -76,12 +76,12 @@
     if py2exe_for_demandload is not None:
         cmdclass['py2exe'] = py2exe_for_demandload
         py2exe_opts['console'] = ['hg']
-    setup(name='mercurial',
+    setup(name='Mercurial',
           version=mercurial.version.get_version(),
           author='Matt Mackall',
           author_email='mpm@selenic.com',
           url='http://selenic.com/mercurial',
-          description='scalable distributed SCM',
+          description='Scalable distributed SCM',
           license='GNU GPL',
           packages=['mercurial', 'hgext'],
           ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
@@ -92,6 +92,10 @@
                        glob.glob('templates/*.tmpl'))],
           cmdclass=cmdclass,
           scripts=['hg', 'hgmerge'],
+          options=dict(bdist_mpkg=dict(zipdist=True,
+                                       license='COPYING',
+                                       readme='contrib/macosx/Readme.html',
+                                       welcome='contrib/macosx/Welcome.html')),
           **py2exe_opts)
 finally:
     mercurial.version.forget_version()